Broken images in Markdown viewer

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
zorglups
Posts: 9
Joined: 29 Jan 2013, 11:24

Broken images in Markdown viewer

Post by zorglups » 17 Sep 2019, 22:01

Hello,

Happy to see support for Markdown in Altap Salamander.

The viewer shows broken images.

If I right click and select "View Source", notepad opens and I see that the image HTML code is this:
<img src=".%5CzZ_assets%5CAnki.assets%5C1546471044201.png" alt="1546471044201" />

If I save the "viewed source" into an html file and view that html file with the Altap Salamander viewer, the image displays fine.

Is that a known problem ?

Thanks,

Pierre

User avatar
SvA
Posts: 461
Joined: 29 Mar 2006, 02:41
Location: DE

Re: Broken images in Markdown viewer

Post by SvA » 18 Sep 2019, 16:59

The viewer uses the about: scheme. Since your url did not use it's own scheme, the viewer could not locate the resource.

It's probably the same reason pressing F5 leaves you with an empty screen.

@Altap: maybe add a <base>-tag pointing to the .md's folder in order to fix @zorglups' problem?

User avatar
SvA
Posts: 461
Joined: 29 Mar 2006, 02:41
Location: DE

Re: Broken images in Markdown viewer

Post by SvA » 27 Nov 2019, 19:12

I now tried to add an image myself. Knowing that a relative path does not work I tried an absolute path, including file: scheme. This cause the resulting src property to be the empty string:

Code: Select all

![Skizze](file://HOST/SHARE/Path/image.jpg)
results in

Code: Select all

<img src="" alt="Skizze" />
Is this a bug or a security feature? Do I need to set up a web server in order to be able to embed pictures?

Post Reply