Virtual Memory leaking when not in use

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
Xyon
Posts: 1
Joined: 13 Apr 2015, 02:16

Virtual Memory leaking when not in use

Post by Xyon » 13 Apr 2015, 02:57

Hi support team

I have a weird issue when Altap Salamander (AS) is running on a remote desktop console:

Scenario is:
I have AS 3.06x64 installed on a server PC. I connect to that server using Windows Remote Desktop and run AS. I then disconnect from that server, leaving my session running.
On this server I also have a remote management & monitoring (RMM) software installed. After a few hours of having disconnected, the RMM reports back to me that AS is using large amounts of physical memory, eg 4GB (out of total of 10GB on this server). The strange thing is that if I re-connect to my remote server session, the memory use of AS immediately drops back to a normal level (eg about 20MB).

Is there a way I can turn on some debugging mechanism in AS that would assist with tracking this, eg have AS write a log file ?

Thanks

Felix
Attachments
2015-04-13 10_48_40-ALPHA_ Memory.jpg
Graph illustrating the issue, the physical is obviously reached the max but the virtual memory is still growing...
2015-04-13 10_48_40-ALPHA_ Memory.jpg (54.68 KiB) Viewed 2163 times
2015-04-13 10_51_49-ALPHA_ Memory.jpg
Nice graph from a few months ago. Here we can see the effect of logging back on releasing all the memory.
2015-04-13 10_51_49-ALPHA_ Memory.jpg (20.94 KiB) Viewed 2163 times

User avatar
Ether
Posts: 1459
Joined: 10 May 2007, 16:08
Location: Czech Republic
Contact:

Re: Virtual Memory leaking when not in use

Post by Ether » 18 Apr 2015, 17:56

You can download the Salamander SDK and run the tracing build of Salamander with a trace server.
Ελληνικά rulez.

Post Reply