Dropping files into AS PB103 x64 not working

Try the latest development release to test new features and bug fixes even before beta version release. Please use this section to discuss features and problems of this Preview Build version.
Forum rules
Please read forum rules and a few additional rules for this section:
1. Please take into account that Preview Build versions of Salamander and plugins could contain serious bugs. Don't use them in production environments.
2. All problems or comments regarding Preview Build versions please insert into this section of forum.
3. Each new topic mark with PB abbreviation and Preview Build number, for example "PB22: inactive panel below mouse cursor doesn't scroll while mouse wheel tilting".
Thunesier
Posts: 5
Joined: 02 Jul 2008, 12:15

Dropping files into AS PB103 x64 not working

Post by Thunesier » 21 Aug 2013, 14:22

In previous versions of Salamander, up to and includiung 3.0 beta 2, I used to be able to drop files into a folder, e.g. by dragging file attachments with the mouse from Outlook to Salamander. In beta 3 PB103 x64 that does not work anymore. :(

therube
Posts: 628
Joined: 14 Dec 2006, 06:22

Re: Dropping files into AS PB103 x64 not working

Post by therube » 21 Aug 2013, 15:53

What OS?
Are Outlook & Salamander running at different privilege levels?
WinXP Pro SP3 or Win7 x86 | SS 2.54

Thunesier
Posts: 5
Joined: 02 Jul 2008, 12:15

Re: Dropping files into AS PB103 x64 not working

Post by Thunesier » 21 Aug 2013, 16:47

Windows 8.
Correct. Salamander was running with admin privileges, Outlook not. When I change Salamander to run without admin privileges, dropping files into Salamander works.
Is this behaviour by design?

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Dropping files into AS PB103 x64 not working

Post by Jan Rysavy » 21 Aug 2013, 17:17

Yes, it is by Windows design.

We will implement the UAC support so you will not need to run Salamander as Administrator.

Andre.Ziegler
Posts: 73
Joined: 10 Mar 2010, 18:31
Location: Germany

Re: Dropping files into AS PB103 x64 not working

Post by Andre.Ziegler » 23 Aug 2013, 09:06

Thunesier wrote:Windows 8.
Correct. Salamander was running with admin privileges, Outlook not.
Is this behaviour by design?
yes this is by design, this is how UAC works. read here about User Interface Privilege Isolation
UIPI prevents a lower privilege application from using Windows messages to send input from one process to a higher privilege process. Sending input from one process to another allows a process to inject input into another process without the user providing keyboard or mouse actions.
http://msdn.microsoft.com/en-us/library/bb530410.aspx

otherwise you can attack admin processes and execute bad code.
"Theory is when you know something, but it doesn't work. Practice is when something works, but you don't know why. Programmers combine theory and practice: Nothing works and they don't know why."

User avatar
crystalidea
Posts: 203
Joined: 09 Dec 2005, 15:13
Contact:

Re: Dropping files into AS PB103 x64 not working

Post by crystalidea » 27 Aug 2013, 19:55

void EnableDragAndDropForElevatedProcess()
{
typedef BOOL (WINAPI *LPFN_CHANGEWINDOWMESSAGEFILTER) (UINT, DWORD);

#define MSGFLT_ADD 1

LPFN_CHANGEWINDOWMESSAGEFILTER fnChangeWindowMessageFilter =
(LPFN_CHANGEWINDOWMESSAGEFILTER)GetProcAddress(GetModuleHandle(TEXT("user32")),"ChangeWindowMessageFilter");

if (NULL != fnChangeWindowMessageFilter)
{
fnChangeWindowMessageFilter (WM_DROPFILES, MSGFLT_ADD);
fnChangeWindowMessageFilter (WM_COPYDATA, MSGFLT_ADD);
fnChangeWindowMessageFilter (0x0049, MSGFLT_ADD);
}
}

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Dropping files into AS PB103 x64 not working

Post by Jan Rysavy » 27 Aug 2013, 20:33

Doesn't look like solution for our problem: http://stackoverflow.com/questions/3794 ... pplication

User avatar
crystalidea
Posts: 203
Joined: 09 Dec 2005, 15:13
Contact:

Re: Dropping files into AS PB103 x64 not working

Post by crystalidea » 27 Aug 2013, 23:57

Actually this function worked for me.

Post Reply