silent uninstall is not working

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
AZI
Posts: 2
Joined: 03 Jul 2019, 17:26

silent uninstall is not working

Post by AZI » 04 Jul 2019, 08:36

Hi guys,

first of all: It's awesome that there is a new version of Salamander after all this time.

My problem right now is, that the silent uninstallation is not working. I've started the remove.exe with the parameter /q (read it from the registry), but instead the uninstall gui appears.

Anyone an idea what's wrong?

best regards

Alex

User avatar
SelfMan
Posts: 941
Joined: 05 Apr 2006, 20:51
Contact:

Re: silent uninstall is not working

Post by SelfMan » 04 Jul 2019, 18:44

Hi,
I dont recall that there was support for silent uninstall. There is only support for silent installation.
https://www.altap.cz/salamander/feature ... alamander/

You dont have to remove the old version prior new install.

AZI
Posts: 2
Joined: 03 Jul 2019, 17:26

Re: silent uninstall is not working

Post by AZI » 05 Jul 2019, 09:42

SelfMan wrote:
04 Jul 2019, 18:44
Hi,
I dont recall that there was support for silent uninstall. There is only support for silent installation.
https://www.altap.cz/salamander/feature ... alamander/

You dont have to remove the old version prior new install.
Hi SelfMan,

thank you for the response. Maybe I got confused by the fact that there is a registry entry present ... Maybe it should be removed in further releases ...

User avatar
SelfMan
Posts: 941
Joined: 05 Apr 2006, 20:51
Contact:

Re: silent uninstall is not working

Post by SelfMan » 05 Jul 2019, 11:42

Yeah, yet you might be right that there is an old bug as the silent uninstall entry is in the registry and says:
C:\Program Files\Altap Salamander\remove\remove.exe /q
its just being ignored.

To be honest, I've NEVER uninstalled Salamander except for testing purposes.
Salamander is the first thing I do install on a fresh computer.

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: silent uninstall is not working

Post by Jan Rysavy » 05 Jul 2019, 11:51

We will look at it, thank you for letting us know...

User avatar
SelfMan
Posts: 941
Joined: 05 Apr 2006, 20:51
Contact:

Re: silent uninstall is not working

Post by SelfMan » 05 Jul 2019, 12:02

Jan, the silent uninstall should be by by default in the state "leave configuration as is".
#MultiUserEnviroment

Post Reply