Altap Salamander 3.0 beta x86 a kompatabilita s Win9x

Vyzkoušejte poslední uveřejněnou vývojovou verzi. Otestujte novinky a opravy chyb ještě před vydáním beta verze. Diskutujte zde o vlastnostech a problémech této Preview Build verze.
Forum rules
Pravidla toho diskuzního fóra jsou k dispozici zde. Navíc prosím dodržujte následující body:
1. Berte prosím na vědomí, že Preview Build verze Salamandera a pluginů mohou obsahovat závažné chyby. Nepoužívejte je v produkčním prostředí.
2. Veškeré chyby, případně připomínky k Preview Build verzím prosím vkládejte do této sekce fóra.
3. Každé nové vlákno označte zkratkou PB a číslem Preview Build verze, například "PB22: neaktivní panel pod kurzorem myši neroluje při naklápění kolečka".
RayeR
Posts: 5
Joined: 17 Apr 2007, 01:09
Location: CZ
Contact:

Altap Salamander 3.0 beta x86 a kompatabilita s Win9x

Post by RayeR » 10 Dec 2012, 12:34

Dobrý den,
léta spokojeně používám Salamandera i na jednom starším PC s Win98SE. Všiml jsem si, že vyšla nová beta 3.0, tak jsem si ji stáhnul na vyzkoušení. Vím, že v systémových požadavcích se změnily nároky na min. Win2000 a vyšší, zajímalo by mě, jestli je to však pro funkci programu nezbytně nutné. Pro Windows 98SE existuje neoficiální rozšíření WinAPI Kernelex ( http://kernelex.sourceforge.net/ ), které implementuje řadu funkcí včetně např unicode a umožňuje tak běh řady novějších programů pod W98SE. Takže jsem to samozřejmě vyzkoušel i na nového Salamandera, ale tady jsem narazil: chbějící export NetShareEnum v netapi32.dll. Jen by mě zajímalo, jestli není možné toto volání nějak jednoduše nahradit a tím vrátit kompatabilitu zpět.

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5127
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Altap Salamander 3.0 beta x86 a kompatabilita s Win9x

Post by Jan Rysavy » 10 Dec 2012, 13:54

Windows 9x kód jsme při přechodu na Visual C++ 2008 pečlivě odstranili a byl to docela balík práce (desítky hodin). Salamander volá mnoho Win32 API, která jsou mezi Win 9x a NT platformou nekompatibilní. Je téměř vyloučeno, že by verze 3.0 pod Win 9x fungovala.

Doporučil bych zůstat na verzi 2.54 a upgradovat až s novým operačním systémem.

RayeR
Posts: 5
Joined: 17 Apr 2007, 01:09
Location: CZ
Contact:

Re: Altap Salamander 3.0 beta x86 a kompatabilita s Win9x

Post by RayeR » 10 Dec 2012, 17:19

OK, dík za odpověd. Mám tomu tedy rozumnět tak, že aby bylo možno Salamandera kompilovat v MSVC2008, bylo nutno vyházet stará API volání protože je MSVC2008 už nepodporuje? Total Commander stále udržuje u 32b verze kompatabilitu pro w95-w8, k tomu mají novou 64b verzi. Ale nevím v čem to překládají. Nicméně uznávám, že Salamander 2.54 mi plně postačuje...

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5127
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Altap Salamander 3.0 beta x86 a kompatabilita s Win9x

Post by Jan Rysavy » 10 Dec 2012, 17:37

Přesně tak, ve Visual C++ 2008 lze překládat pro operační systémy Windows 2000 a novější. Runtime knihovny, které jsou součástí výsledného kódu, Win 9x nepodporují.
Viz například http://stackoverflow.com/questions/2137 ... windows-98

Podporovat z jednoho kódu a projektu současně Visual C++ 2008, 2010 a 2012 bylo poměrně schůdné, takže nyní můžeme překládat ve všech třech verzích překladače. Překládat speciální Windows 9x verzi by určitě bylo proveditelné, ale nákladné. Jste první uživatel, který se ozval, takže jsme zřejmě udělali správné rozhodnutí. Další logický krok bude zahození podpory pro Windows 2000, což by nám usnadnilo testování. Nyní každé vydávané EXE (x86/x64) testujeme pod Windows 2000, Windows XP, Windows Vista, Windows 7 a Windows 8, což je časově náročné.

User avatar
Ether
Posts: 1459
Joined: 10 May 2007, 16:08
Location: Czech Republic
Contact:

Re: Altap Salamander 3.0 beta x86 a kompatabilita s Win9x

Post by Ether » 11 Dec 2012, 15:09

RayeR wrote:chbějící export NetShareEnum v netapi32.dll
Čistě pro zajímavost, je toto jediná funkce, která na vašem systému chybí, nebo je pouze první (z mnoha?), na které to padlo?
Ελληνικά rulez.

Post Reply