[bug] Synaptics touchpad - scrolling doesn't work

Try the latest development release to test new features and bug fixes even before beta version release. Please use this section to discuss features and problems of this Preview Build version.
Forum rules
Please read forum rules and a few additional rules for this section:
1. Please take into account that Preview Build versions of Salamander and plugins could contain serious bugs. Don't use them in production environments.
2. All problems or comments regarding Preview Build versions please insert into this section of forum.
3. Each new topic mark with PB abbreviation and Preview Build number, for example "PB22: inactive panel below mouse cursor doesn't scroll while mouse wheel tilting".
azaz44
Posts: 25
Joined: 03 Jan 2012, 13:04

[bug] Synaptics touchpad - scrolling doesn't work

Post by azaz44 » 14 Oct 2012, 12:23

Hello

I'm using PB87 on Win7 Pro, 64-bit on HP8560w notebook with Synaptics touchpad, with latest drivers. WIth this touchpad you can scroll content in all applications using two fingers at the same time (multi touch). This doesn't work in AS. Mouse cursor changes to scrolling indicator, but nothing moves.

I have no idea if it ever worked in AS 2.54, because with new laptop I started with everything 64-bit.

Besides that I have to say another time, AS is just great. If it costs money to switch to 3.0 I'll definitly spend it. Best productivity tool I have, absolutly!. How much I wish, we ever get some e-mail client so good, and made with same spirit like AS...

User avatar
Ether
Posts: 1459
Joined: 10 May 2007, 16:08
Location: Czech Republic
Contact:

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by Ether » 14 Oct 2012, 23:16

Well, from my experience, touchpad drivers aren't exactly the paragon of compatibility. My drivers won't scroll in Thunderbird (although they do in Firefox). Could you try AS v2.54 and AS v3.0b 32-bit and tell us if they behave differently?
Ελληνικά rulez.

azaz44
Posts: 25
Joined: 03 Jan 2012, 13:04

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by azaz44 » 30 Nov 2012, 09:42

I didn't verify if it works with older versions, because I cannot mess my system right now.

I tested another option - instead of using multitouch I enabled standard touchpad scrolling, where you use your very right area of the touchpad to scroll with one finger. This doesn't work with AS either.

I also tested similar functionality but with Wacom Bamboo 3 tablet and here it works fine.

The difference is, when you try with Bamboo it just scrolls, but mouse cursor doesn't change. When you do this with Synaptics, the mouse cursor changes to indicate scrolling. I guess they send different events too.

Also, I tested that my Synaptics touchpad scrolling works in every other applications, including very old stuff released at time of Windows 95, so I think AS simply ignores some event what always existed.

azaz44
Posts: 25
Joined: 03 Jan 2012, 13:04

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by azaz44 » 30 Nov 2012, 09:51

Ok, I did another test. Here are snapshots of Spy++ (64-bit) tracking one of AS panels, while trying to scroll a long list of files.

Scrolling with Wacom Bamboo 3 (works):
Scrolling_with_Bamboo.PNG
Scrolling_with_Bamboo.PNG (136.05 KiB) Viewed 11296 times
Scrolling with Synaptics touchpad (doesn't work):
Scrolling_with_Touchpad.PNG
Scrolling_with_Touchpad.PNG (126.36 KiB) Viewed 11296 times

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by Jan Rysavy » 30 Nov 2012, 22:23

Thank you for detailed information. We did some changes in mouse wheel handling, please try AS 3.0 beta 1 and let us know.

azaz44
Posts: 25
Joined: 03 Jan 2012, 13:04

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by azaz44 » 30 Nov 2012, 22:48

Jan Rysavy wrote:Thank you for detailed information. We did some changes in mouse wheel handling, please try AS 3.0 beta 1 and let us know.
Thanks for the update. Just installed and seems to work fine so far. But the problem is still not resolved. Tested on the touchpad - doesn't work. And on Bamboo - works like before. Besides that I get such screens at installation time:
setup.PNG
setup.PNG (32.57 KiB) Viewed 11260 times
My DPI is set to 110%. My guess is, it would work properly at 100%, but probably not at 125% which is Win7 default.

In any case, it's great to see a new release! Best productivity tool ever.

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by Jan Rysavy » 30 Nov 2012, 22:53

Thank you for info. I will contact you directly during next week with some special build of Salamander - we should be able to fix such stupid problem :)

I will also test 110% DPI setup.

azaz44
Posts: 25
Joined: 03 Jan 2012, 13:04

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by azaz44 » 30 Nov 2012, 23:23

Jan Rysavy wrote:Thank you for info. I will contact you directly during next week with some special build of Salamander - we should be able to fix such stupid problem :)

I will also test 110% DPI setup.
Great, I'll be happy to help!

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by Jan Rysavy » 02 Dec 2012, 09:46

High DPI problem is fixed. Altap Salamander is now declared as High-DPI application.
Also missing context menu icons for DPI > 100% are fixed.

azaz44
Posts: 25
Joined: 03 Jan 2012, 13:04

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by azaz44 » 02 Dec 2012, 11:16

I didn't test because I don't see any new version to download. But it's great to hear problems are getting fixed ;)

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by Jan Rysavy » 02 Dec 2012, 13:13

It is work in progress, it will be included in the special Salamander build for your test.

Petr Solin
ALTAP Staff
ALTAP Staff
Posts: 1110
Joined: 08 Dec 2005, 09:13
Location: Novy Bor, Czech Republic
Contact:

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by Petr Solin » 10 Dec 2012, 15:34

Please change your DPI to 100% and then try to test scrolling with your touchpad. I have noticed that hit-test regions for left/right panel are probably not properly transformed, so e.g. when I set 125% DPI and mouse is in right bottom part of right panel, it does not scroll even with my mouse.

User avatar
SvA
Posts: 448
Joined: 29 Mar 2006, 02:41
Location: DE

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by SvA » 10 Dec 2012, 23:03

Jan Rysavy wrote:High DPI problem is fixed. Altap Salamander is now declared as High-DPI application.
Also missing context menu icons for DPI > 100% are fixed.
What exactly do you mean by this? and does it apply to 3.0 Beta 1?

Beta 1 (neither x86 not x64) does not declare itself to be dpi aware as described in Declaring DPI Awareness using the manifest.

Although MS declares to only use dpi virtualization from 120% dpi on, the effect described in the previous post is likely a result of dpi virtualization, although some eroneous API call (or even a wrong implementation on MS's part) might be the cause as well. I do not have programming experience on this myself.

azaz44
Posts: 25
Joined: 03 Jan 2012, 13:04

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by azaz44 » 11 Dec 2012, 09:14

Just a quick thing to mention - the screenshots I posted are from the setup program, not AS. How AS behaves might be a different thing. I don't know if it's DPI aware. It works fine for me, but I just configured the font size so it looks good.

I will test the touchpad with 100%, but I hardly imagine it would change anything.

azaz44
Posts: 25
Joined: 03 Jan 2012, 13:04

Re: [bug] Synaptics touchpad - scrolling doesn't work

Post by azaz44 » 11 Dec 2012, 09:27

Setting DPI to 100% didn't change anything if it comes to scrolling.

Jan: how about this special build to test?

Post Reply