PictView thumbnails problems crashing salamander

Try the latest development release to test new features and bug fixes even before beta version release. Please use this section to discuss features and problems of this Preview Build version.
Forum rules
Please read forum rules and a few additional rules for this section:
1. Please take into account that Preview Build versions of Salamander and plugins could contain serious bugs. Don't use them in production environments.
2. All problems or comments regarding Preview Build versions please insert into this section of forum.
3. Each new topic mark with PB abbreviation and Preview Build number, for example "PB22: inactive panel below mouse cursor doesn't scroll while mouse wheel tilting".
User avatar
Georgd
Posts: 97
Joined: 24 Jul 2006, 17:13

PictView thumbnails problems crashing salamander

Post by Georgd » 24 Oct 2012, 10:46

Hello!

On http://www.altap.cz/salamander/downloads/eap/ you requested "Please focus on testing PictView plugin with your images.". I did use 3.0 beta 1 (PB87) (released 7/27/2012) on my Win 7 home premium 64bit German for 2 minutes and found 2 bugs in PictView:

1) The well-known bug that mode right > thumbnails only for some pictures a thumbnail is shown, see old bug report or try yourself with this picture (just one example out of hundrets)

2) I hoped to workaround the problem when PictView creates the thumbail itself as in Salamander 2.54. Hence, I opened Plugins > PictView > Update Thumbnail. Only during the first try (which I think is odd) after several seconds of nothing happening I got a message about not enough RAM - I had around 2 GB of free RAM as you can see on the next image - and then the further messages I also got after restarting Salamander: Error message 1 (could not load process) and directly afterwards Error message 2 (also about unability to load process). Then, Salamader crashed and requested me to send a bug report (I did so and linked to this forum entry). In Salamander 2.54, this was working fine.

Cheers,
Georg
Using Salamander since v 1.52

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5127
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: PictView thumbnails problems crashing salamander

Post by Jan Rysavy » 24 Oct 2012, 11:52

Thank you for your report. We are forwarding this problem to Jan Patera - author of the PictView plugin.

Jan Patera
Plugin Developer
Plugin Developer
Posts: 707
Joined: 08 Dec 2005, 14:33
Location: Prague, Czech Republic
Contact:

Re: PictView thumbnails problems crashing salamander

Post by Jan Patera » 25 Oct 2012, 09:22

Georgd wrote:2) I hoped to workaround the problem when PictView creates the thumbail itself as in Salamander 2.54. Hence, I opened Plugins > PictView > Update Thumbnail. Only during the first try (which I think is odd) after several seconds of nothing happening I got a message about not enough RAM - I had around 2 GB of free RAM as you can see on the next image - and then the further messages I also got after restarting Salamander:
Indeed, I am getting crashes when uipdating thumbnail of your JPG in the X64 version. I will have a look. Thanks for reporting!

Jan Patera
Plugin Developer
Plugin Developer
Posts: 707
Joined: 08 Dec 2005, 14:33
Location: Prague, Czech Republic
Contact:

Re: PictView thumbnails problems crashing salamander

Post by Jan Patera » 15 Nov 2012, 22:45

Fixed for the next release/build.

Post Reply