internal text files viewer

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
tzurs
Posts: 1
Joined: 16 Aug 2009, 23:19

internal text files viewer

Post by tzurs » 16 Aug 2009, 23:24

Hi,

some simple text files when opened for view (f3)
are displayed incorrectly
as one long column one letter in each row,
I can't make out which text files are displayed as such but here's a simple one that
has this problem,

this is really bothering, notepad and other editors open this file without a glitch,
I've tried using the convert feature of the viewer but I can't see any utf/unicode options there, i believe these files
maybe utf or java utf
anyone has an idea?
--tzurs
love the salamander
Attachments
eula.1028.txt
(17.32 KiB) Downloaded 184 times

User avatar
Ether
Posts: 1459
Joined: 10 May 2007, 16:08
Location: Czech Republic
Contact:

Re: internal text files viewer

Post by Ether » 17 Aug 2009, 00:00

tzurs wrote:some simple text files when opened for view (f3)
are displayed incorrectly
as one long column one letter in each row
I believe the file is UTF-16 encoded (though I didn't bother to look at it), which is unfortunately Microsoft's favorite. Salamander can't display these files correctly, however it's planned that this feature be implemented. See a random thread about Unicode support for more information, or search for Unicode in the forums.
Ελληνικά rulez.

User avatar
zarevak
Plugin Developer
Plugin Developer
Posts: 789
Joined: 04 Feb 2006, 16:49
Location: Prague, Czech Republic

Re: internal text files viewer

Post by zarevak » 17 Aug 2009, 00:34

Try to deselect NULL as Line Ending character in Internal Viewer Configuration - it won't be perfect, but at least you would be able to recognize basic file structure...

From Salamander main window: menu" Options" > "Configuration..." in the tree item "Viewers & Editors" subitem "Internal Viewer" and deselect NULL in the first section.
From Internal Viewer window: menu" Options" > "Configuration..." - the tree item "Viewers & Editors" subitem "Internal Viewer" will be automatically selected - deselect NULL in the first section.

To Altap: I think it should be deselected by default option because of wider and wider spread of files in UTF-16 encoding...

pjo
Posts: 2
Joined: 05 Jan 2015, 19:44

Re: internal text files viewer

Post by pjo » 05 Jan 2015, 19:59

Hi!
I have the same problem, but it's not just related to the internal viewer. When i try to find text in these files, Altap doesn't find it. And so when pressing "F3" i see that the text is in one column. So changing the internal viewer doesn't solve the problem.

Doing as suggested produces a view of the file similar to:

E"some char"x"some char"a"some char"c"some char"t"some char" etc. Fiddling with the "Line end" options a little bit more results in a HEX-like view.

But as stated before i want to be able to search in this file and the only way to do this is to convert the file. :(

Altap 2.54, 3.0 and 3.05 was used.

Thanks in advance.

Post Reply