Corrupted configuration

We welcome any suggestions for new features or improvements in Altap Salamander. Please post one suggestion per report.
Dangph
Posts: 9
Joined: 03 Sep 2010, 02:17

Corrupted configuration

Post by Dangph » 19 Apr 2011, 07:06

I've gotten a corrupted configuration twice now. It's really annoying.
Altap Salamander 2.54

Configuration stored in registry is corrupted, so it cannot be loaded. Altap Salamander was probably terminated during saving configuration. This happens mainly when Altap Salamander is still running when you shutdown system (or log off). To prevent this problem, close Altap Salamander before shutdown (or log off).
I notice in that error message that I should "close Altap Salamander before shutdown (or log off)". Should I really have to do that? I have enough things to remember in my life already.

I am wondering why Salamander can't just simply save its configuration immediately after the user changes a setting, that is, after they close the options dialog.

User avatar
SelfMan
Posts: 955
Joined: 05 Apr 2006, 20:51
Contact:

Re: Corrupted configuration

Post by SelfMan » 20 Apr 2011, 05:44

You really should check THIS thread.

Dangph
Posts: 9
Joined: 03 Sep 2010, 02:17

Re: Corrupted configuration

Post by Dangph » 30 May 2011, 04:51

Thanks, SelfMan, but I don't feel that I should have to tweak system registry settings. Save-on-exit seems like a misfeature.

Anyway, I found a work-around: Uncheck "Save configuration on exit" in the options, and do the Save Configuration manually.

Post Reply