FTP panel option -- view filenames as they're stored on disk

We welcome any suggestions for new features or improvements in Altap Salamander. Please post one suggestion per report.
User avatar
TimeGhost
Posts: 16
Joined: 27 Jan 2006, 20:00
Location: Northeastern USA

FTP panel option -- view filenames as they're stored on disk

Post by TimeGhost »

I like working with SS configured to show file names in lower case, with directories in upper case. Under Windows, case doesn't matter. And I can right-click a file, choose Properties, and see the file name as it's stored on disk.

But now that I can FTP to computers where case does matter, the setting is a great hindrance. It would be great if one of the following were available:

1. Right-click to show properties of a file on a remote FTP server. This would show the file name in the case as it's stored on the remote drive. (Ctrl-F2 should show it this way, too.)

2. Add a new configuration setting that allows for different display of case for local file names / directories versus remote file names / directories. This way one could set local file names to display as lower case with local directories in upper case. And the setting could be different for remote drives and FTP servers -- show names as they're stored on disk.

For now I'll probably change the setting manually each time I connect to an FTP server.

TIA
Petr Solin
ALTAP Staff
ALTAP Staff
Posts: 1111
Joined: 08 Dec 2005, 09:13
Location: Novy Bor, Czech Republic
Contact:

Post by Petr Solin »

I think that using case-sensitive FTP with this option (display lower case names) is not good idea and neither of your suggestions will solve it. You need to see names in original case also on disk (not only on FTP), otherwise you can't know target name when uploading file from disk to FTP.

I don't see any good solution to this problem, so I recommend not to use this feature when working with FTP.
User avatar
TimeGhost
Posts: 16
Joined: 27 Jan 2006, 20:00
Location: Northeastern USA

Post by TimeGhost »

Thanks, Petr. I've been keeping the feature turned off. It's not too bad this way.
Post Reply