FILE_FLAG_NO_BUFFERING option in Copy dialog (large files)

We welcome any suggestions for new features or improvements in Altap Salamander. Please post one suggestion per report.
rts
Posts: 3
Joined: 14 Sep 2009, 14:23

FILE_FLAG_NO_BUFFERING option in Copy dialog (large files)

Post by rts » 17 Jul 2015, 16:02

Hello,

Could you please add option 'FILE_FLAG_NO_BUFFERING' to Copy/Move/Rename Options window ?

It would help us to copy/move large/huge files (e.g. *.vhd/*.tib/*.7z/*.zip volumes/archives with size of 100 GB and more) without depleting all available memory that is eventually consumed by Windows for I/O cache. Once the memory is depleted, Windows starts swapping and becomes unresponsive (i.e. very slow) for all other actions.

Thank you.

Radomir Tomis

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: FILE_FLAG_NO_BUFFERING option in Copy dialog (large file

Post by Jan Rysavy » 10 Nov 2015, 08:53

This sounds strange, we are reading files with limited buffer (maybe up to 256KB). I can imagine OS will allocate some internal buffers but if it starts swapping, I think there is something very wrong. Do you have any information about this problem?

User avatar
Ether
Posts: 1459
Joined: 10 May 2007, 16:08
Location: Czech Republic
Contact:

Re: FILE_FLAG_NO_BUFFERING option in Copy dialog (large file

Post by Ether » 11 Nov 2015, 12:50

It's not the first time I heard about such a thing. Could it be this? https://support.microsoft.com/en-us/kb/976618
Ελληνικά rulez.

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: FILE_FLAG_NO_BUFFERING option in Copy dialog (large file

Post by Jan Rysavy » 11 Nov 2015, 16:37

Interesting.

rts, what Windows version are you using? Could you reproduce this problem according to MS article?

Post Reply