Page 1 of 1

permanent error 4 copying files

Posted: 25 Mar 2015, 17:04
by mfromg

i try to copy a lot of files (a lot of means maybe 20000 - 30000). the files are small like epub and mp3.
after a long time Salamnder is check the files it starts the copy.
now always after a few files(maybe 100) i get the error message (Fehler(4). Das System kann die Datei nicht öffnen).
Means translatetd: Error(4). the system cannot open the file.
if i wait a minute or less and press retry, the copy runs and after a few files the same procedure.
I'm not sure its really a problem of salamander, can be also a problem of the system
(maybe not enough handles or anything like that).
I use windows 7 64bit in german. and is use Altap Salamander 3.06(x64).
Anything i can do beside pressing million times "retry" ?



Re: permanent error 4 copying files

Posted: 25 Mar 2015, 20:52
by SelfMan
Have you tried Windows Explorer or a different filemanager? (Total Commander).
Do you have a antivirus running? If so, have you tried to disable it temporarily" What is the system configuration?
You didn't give any specifics.

Re: permanent error 4 copying files

Posted: 26 Mar 2015, 07:57
by mfromg
first I have to say, the problem appeared the first time,
as I copied the files.
In this case I got sometimes the error network connection lost.
if I tried the network connection wirh another program (explorere),
the network-connection is fine. if I wait a minute or less and press
"try agian", it runs forward.
because I had so many interuptions during the copy-session,
I now to copy the files again. if the files exist, I press
skip it. in this case, i have the behaviour i wrote in may
first text.
I closed my antvir program (kasperski) and the error comes.
I tried now with totalcommander. i have the same problem,
only the message is another. TC says (cannot write the file,
maybe remove the wrote-protection). I wait and press
"retry" and it runs forward.
now searched the net about the problem and found,
many other people had the same problem.
So it's not a problem of salamander, it seems a problem
of my operating system.

sorry wasting your time here .....

for other persons searching a solution. i copy my files now
with the micrsoft tool "RichCopy", works fine in this case.
(many small files)

Re: permanent error 4 copying files

Posted: 26 Mar 2015, 08:06
by SelfMan
See, that is one thing you did not mention before, that you are copying the files over the network.
You should update your chipset, bios and network drivers. (check, let it scan your sysytem and update everything)