Internet Explorer Viewer - not HTML5 compatible

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
User avatar
crystalidea
Posts: 203
Joined: 09 Dec 2005, 15:13
Contact:

Internet Explorer Viewer - not HTML5 compatible

Post by crystalidea » 20 Feb 2015, 03:57

Looks like Internet Explorer Viewer is using some old HTML engine (some compatibility mode set?)

IE 11, Win7 x64

Update: it uses IE7 compatibility mode

therube
Posts: 626
Joined: 14 Dec 2006, 06:22

Re: Internet Explorer Viewer - not HTML5 compatible

Post by therube » 20 Feb 2015, 15:49

I was always of the impression that the IE Viewer was nothing more then an interface into Windows IE components.
So settings in IE affect what IE Viewer does.
And failings in IE likewise would show up in IE Viewer.

Does the particular webpage/html "document" display properly in IE itself?
WinXP Pro SP3 or Win7 x86 | SS 2.54

User avatar
crystalidea
Posts: 203
Joined: 09 Dec 2005, 15:13
Contact:

Re: Internet Explorer Viewer - not HTML5 compatible

Post by crystalidea » 20 Feb 2015, 20:22

therube wrote:Does the particular webpage/html "document" display properly in IE itself?
Absolutely. And it's totally broken in AS. The same can be achieved in normal IE when setting IE7 mode (F12)

User avatar
Ether
Posts: 1459
Joined: 10 May 2007, 16:08
Location: Czech Republic
Contact:

Re: Internet Explorer Viewer - not HTML5 compatible

Post by Ether » 22 Feb 2015, 17:42

therube wrote:I was always of the impression that the IE Viewer was nothing more then an interface into Windows IE components.
Yes, but the choice of rendering mode is up to the interface user. The default rendering mode cannot be changed just by installing a new version of IE, because that would break existing applications that rely on the quirks of older IE's.
Ελληνικά rulez.

odinuv
Posts: 9
Joined: 02 May 2014, 08:58

Re: Internet Explorer Viewer - not HTML5 compatible

Post by odinuv » 30 Jul 2015, 11:43

Ether wrote:Yes, but the choice of rendering mode is up to the interface user. The default rendering mode cannot be changed just by installing a new version of IE, because that would break existing applications that rely on the quirks of older IE's.
Not at all. See https://msdn.microsoft.com/en-us/librar ... 85%29.aspx As long as there is proper DOCTYPE, the rendering mode is Edge. Unless of course something else is forcing it to downgrade which happens in case of AS viewer.

edwallk
Posts: 3
Joined: 10 Jul 2006, 07:44

Re: Internet Explorer Viewer - not HTML5 compatible

Post by edwallk » 19 Nov 2015, 01:33

You can actually manually configure what emulation IE will use for AS by editing your registry. Have a look at https://msdn.microsoft.com/en-us/librar ... s.85).aspx for example for details.

therube
Posts: 626
Joined: 14 Dec 2006, 06:22

Re: Internet Explorer Viewer - not HTML5 compatible

Post by therube » 19 Nov 2015, 07:19

WinXP Pro SP3 or Win7 x86 | SS 2.54

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Internet Explorer Viewer - not HTML5 compatible

Post by Jan Rysavy » 19 Nov 2015, 08:46

Does it really work for Salamander and IE Viewer? Please let us know, I didn't investigate this problem yet.

edwallk
Posts: 3
Joined: 10 Jul 2006, 07:44

Re: Internet Explorer Viewer - not HTML5 compatible

Post by edwallk » 20 Nov 2015, 07:08

I've successfully used it in our own product and as long as you set the flag in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION before the executable loads IE it will work. I just tried myself just now by creating a DWORD value called salamand.exe and setting the value to 11001 (decimal) and Salamander will now render pages using IE11 instead of using the default compatibility mode.

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Internet Explorer Viewer - not HTML5 compatible

Post by Jan Rysavy » 26 Nov 2015, 11:11

It works also with HKCU key: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

We can write value 11000 (IE11. Webpages containing standards-based !DOCTYPE directives are displayed in IE11 edge mode. Default value for IE11.) in AS installer. It works fine in XP with IE8 too.

Post Reply