F4 starts magnifier

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
mdusek
Posts: 24
Joined: 27 Oct 2006, 16:58

F4 starts magnifier

Post by mdusek » 14 Dec 2014, 23:07

It has happened already in two of my Win 7 computers that F4 starts magnifier instead of editor. I would be grateful for any advice how to regain the correct functionality of F4. Best regards, Michal

User avatar
SelfMan
Posts: 925
Joined: 05 Apr 2006, 20:51
Contact:

Re: F4 starts magnifier

Post by SelfMan » 15 Dec 2014, 03:33

Is it possible that its just a notebook function keys feature?
What happens when you use Fn+F4?

mdusek
Posts: 24
Joined: 27 Oct 2006, 16:58

Re: F4 starts magnifier

Post by mdusek » 15 Dec 2014, 08:36

In this laptop Fn+F4 is Sleep. Moreover, this happenes also in one my desktop PC.

User avatar
SelfMan
Posts: 925
Joined: 05 Apr 2006, 20:51
Contact:

Re: F4 starts magnifier

Post by SelfMan » 15 Dec 2014, 09:03

Then it must be some software/tool which you've installed on both computers.
Still check "Options > Configuration > Viewers and editors > Editors" and post a screenshot.

mdusek
Posts: 24
Joined: 27 Oct 2006, 16:58

Re: F4 starts magnifier

Post by mdusek » 15 Dec 2014, 09:15

This looks as usually. Some external program has stolen F4, so the question is if Salamander can get it back. I will try to reinstall it.
Attachments
ScreenHunter_00339.jpg
ScreenHunter_00339.jpg (78.03 KiB) Viewed 5973 times

User avatar
SelfMan
Posts: 925
Joined: 05 Apr 2006, 20:51
Contact:

Re: F4 starts magnifier

Post by SelfMan » 15 Dec 2014, 10:12

How does Salamander behave in case where you replace the gvim.exe with notepad.exe?
There is also the question what happens when you push the F4 key while Salamander's window is not active.

mdusek
Posts: 24
Joined: 27 Oct 2006, 16:58

Re: F4 starts magnifier

Post by mdusek » 15 Dec 2014, 11:40

Gvim/notepad has no influence. F4 works the same way with active Salamander window as well as without it: it magnifies the screen and changes the mouse cursor to a pen so I get amazing possibility to plot on the screen instead of editing. The other F keys are working normally.

User avatar
SelfMan
Posts: 925
Joined: 05 Apr 2006, 20:51
Contact:

Re: F4 starts magnifier

Post by SelfMan » 15 Dec 2014, 12:15

This just confirms that this is not a salamander issue, but an external utility which is hooked on the F4 key.
Do you have any screen capturing utility installed?

mdusek
Posts: 24
Joined: 27 Oct 2006, 16:58

Re: F4 starts magnifier

Post by mdusek » 15 Dec 2014, 12:33

Exactly.
My screen capturing sw uses Ctrl-Printscreen.
I reinstalled Salamander but it does not help.
OK, I will live without F4 until I discover which program uses it.
Thank you for your help, anyway.

User avatar
SelfMan
Posts: 925
Joined: 05 Apr 2006, 20:51
Contact:

Re: F4 starts magnifier

Post by SelfMan » 15 Dec 2014, 13:21

Try to shut down the screencapturing tool an check what happens.

User avatar
SvA
Posts: 441
Joined: 29 Mar 2006, 02:41
Location: DE

Re: F4 starts magnifier

Post by SvA » 16 Dec 2014, 00:28

It might also be just the Windows shell. Please check all links (shortcuts) in your user profile and the all users profile, especially those on the desktop and in the start menu. They have a hotkey setting that easily interferes anywhere when used. Best start to check the one labeled as screen magnifier in the accessibility group of the all programs submenu.

mdusek
Posts: 24
Joined: 27 Oct 2006, 16:58

Re: F4 starts magnifier

Post by mdusek » 26 Dec 2014, 22:53

Thank you both guys for hints! I have just discovered that F4 was blocked by AutoScreeRecorder 3.1 of Wisdom Soft.
Best wishes,
Michal

User avatar
SelfMan
Posts: 925
Joined: 05 Apr 2006, 20:51
Contact:

Re: F4 starts magnifier

Post by SelfMan » 26 Dec 2014, 23:14

You are welcome.

Post Reply