Page 1 of 1

Salamander shows '?' instead of ','

Posted: 18 May 2020, 22:24
by Slavian
Hello.

My Altap Salamander shows '?' instead of ',' in 'size' column. See the attached screenshot.
I'm running Windows 10 x64 1909, Salamander 4.0 x64.
1.png
1.png (15.09 KiB) Viewed 1956 times
As you can see it shows Russian symbols properly.

Re: Salamander shows '?' instead of ','

Posted: 19 May 2020, 12:18
by SelfMan
Go to
Control Panel\Clock and Region > Region
TAB Administrative > Change system locale
Disable checkbox on "[X] Beta: Use Unicode UTF-8 for worldwide language support"

Dont forget to set your proppper "Current system locale" in the pulldown menu above (if not set).

After you change the setting, reboot the computer.

Re: Salamander shows '?' instead of ','

Posted: 26 May 2020, 20:43
by Slavian
Yep, fixed!

Re: Salamander shows '?' instead of ','

Posted: 26 May 2020, 20:58
by SelfMan
Slavian wrote: 26 May 2020, 20:43Yep, fixed!
You are welcome...

Re: Salamander shows '?' instead of ','

Posted: 17 Oct 2020, 13:25
by finale
Slavian wrote: 18 May 2020, 22:24 I'm running Windows 10 x64 1909, Salamander 4.0 x64.
Interesting that in Windows 10 x64 2004 and same Salamander version there is no such a problem, even when UTF-8 locale is enabled.