Page 1 of 1

silent uninstall is not working

Posted: 04 Jul 2019, 08:36
by AZI
Hi guys,

first of all: It's awesome that there is a new version of Salamander after all this time.

My problem right now is, that the silent uninstallation is not working. I've started the remove.exe with the parameter /q (read it from the registry), but instead the uninstall gui appears.

Anyone an idea what's wrong?

best regards

Alex

Re: silent uninstall is not working

Posted: 04 Jul 2019, 18:44
by SelfMan
Hi,
I dont recall that there was support for silent uninstall. There is only support for silent installation.
https://www.altap.cz/salamander/feature ... alamander/

You dont have to remove the old version prior new install.

Re: silent uninstall is not working

Posted: 05 Jul 2019, 09:42
by AZI
SelfMan wrote:
04 Jul 2019, 18:44
Hi,
I dont recall that there was support for silent uninstall. There is only support for silent installation.
https://www.altap.cz/salamander/feature ... alamander/

You dont have to remove the old version prior new install.
Hi SelfMan,

thank you for the response. Maybe I got confused by the fact that there is a registry entry present ... Maybe it should be removed in further releases ...

Re: silent uninstall is not working

Posted: 05 Jul 2019, 11:42
by SelfMan
Yeah, yet you might be right that there is an old bug as the silent uninstall entry is in the registry and says:
C:\Program Files\Altap Salamander\remove\remove.exe /q
its just being ignored.

To be honest, I've NEVER uninstalled Salamander except for testing purposes.
Salamander is the first thing I do install on a fresh computer.

Re: silent uninstall is not working

Posted: 05 Jul 2019, 11:51
by Jan Rysavy
We will look at it, thank you for letting us know...

Re: silent uninstall is not working

Posted: 05 Jul 2019, 12:02
by SelfMan
Jan, the silent uninstall should be by by default in the state "leave configuration as is".
#MultiUserEnviroment

Re: silent uninstall is not working

Posted: 02 Aug 2019, 11:49
by Max Prang
Hi Guys.

If you have access to version 3.08, you can replace the ver 4.0 remove with the ver 3.08, and the silent removal works again.
It even removes the ver. 4.0 uninstall entry from registry.

We administrators love to be albe to silent remove software, its seldom used, but nice to have.

Regards Max

Re: silent uninstall is not working

Posted: 05 Sep 2019, 09:37
by AZI
Max Prang wrote:
02 Aug 2019, 11:49
Hi Guys.

If you have access to version 3.08, you can replace the ver 4.0 remove with the ver 3.08, and the silent removal works again.
It even removes the ver. 4.0 uninstall entry from registry.

We administrators love to be albe to silent remove software, its seldom used, but nice to have.

Regards Max
awesome idea!

Re: silent uninstall is not working

Posted: 05 Sep 2019, 14:37
by tukanos
Max Prang wrote:
02 Aug 2019, 11:49
Hi Guys.

If you have access to version 3.08, you can replace the ver 4.0 remove with the ver 3.08, and the silent removal works again.
It even removes the ver. 4.0 uninstall entry from registry.

We administrators love to be albe to silent remove software, its seldom used, but nice to have.

Regards Max
We had similar discussion at czech part of the forum - viewtopic.php?f=6&p=68536#p68536

The switch combination which is usable for 4.0 is:

Code: Select all

as40x64.exe /x /s /id y /is n /au y