Focus gets lost after COPY,MOVE

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
tdrees
Posts: 10
Joined: 13 Dec 2005, 20:14

Focus gets lost after COPY,MOVE

Post by tdrees » 08 Dec 2010, 12:31

Hi, when I am copying files with the latest Salamander (2,54) the focus of the window gets lost. So the bar indicating the marked row/file is lost. If I hit "ALT+F4" it comes back. Any idea, what this could be?

Thanks and Regards,

Torsten

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5126
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Focus gets lost after COPY,MOVE

Post by Jan Rysavy » 08 Dec 2010, 15:17

Hi, it looks you are longtime user of Salamander and this problem looks to be new?
Did you install any software recently? Or did you switch Windows recently?

tdrees
Posts: 10
Joined: 13 Dec 2005, 20:14

Re: Focus gets lost after COPY,MOVE

Post by tdrees » 08 Dec 2010, 15:28

Hi Jan, yes I am a very long time user. The problem is relativly new, but can be reproduced an another machine also, both Windows 7 (one 32- the other on 64 bit). The OS is installed much longer.

Regards,

Torsten

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5126
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Focus gets lost after COPY,MOVE

Post by Jan Rysavy » 08 Dec 2010, 17:38

It would be caused by some software installed on both your computers. Do you have any idea about recently installed software?

We didn't change Salamander window activation routines several years now...

therube
Posts: 608
Joined: 14 Dec 2006, 06:22

Re: Focus gets lost after COPY,MOVE

Post by therube » 09 Dec 2010, 04:12

Alt+F4 is typically used to close a window.
So if Alt+F4 is returning focus to Salamander, what might be closing?

A copy dialog runs asynchronously (after it has enumerated all the selected files/directories).

Using a laptop? Inadvertently dragging across the scroll pad or something like that?

...

Now there are times when focus switches away (I just don't remember the circumstances) ... Next time I see it (& I will), I'll note it.

When I open an FTP site, there is typically a delay after the 'Welcome Message' displays & when focus actually returns to it. So I learned to hesitate slightly before continuing, so as to first successfully "hit" the Close button on that dialog box.

If a file is deleted, recreated (as like what the VIM editor may do), then focus position, while not lost, may change.
Here, Panel Row Focus Changes when Editing with VIM.
WinXP Pro SP3 or Win7 x86 | SS 2.54

User avatar
stepand76
Plugin Developer
Plugin Developer
Posts: 453
Joined: 16 Apr 2007, 21:22
Location: Pardubice, Czech Republic

Re: Focus gets lost after COPY,MOVE

Post by stepand76 » 09 Dec 2010, 09:07

Torsten, do you use a program which is configured to be stay on top? Look on this issue. Strange is that last year it works fine for (no problem with focus lost).

Edit: Sorry, now I see it is czech issue...

User avatar
ino
Posts: 440
Joined: 09 Dec 2005, 14:59
Location: Brno, Czech Republic

Re: Focus gets lost after COPY,MOVE

Post by ino » 09 Dec 2010, 09:48

therube wrote:Alt+F4 is typically used to close a window.
So if Alt+F4 is returning focus to Salamander, what might be closing?
tdrees, hit Alt+Tab just after the copying files operation is finished and your Salamander lost its focus. There you will see list of applications - I guess it will be the very first icon from left which get the focus instead of Salamander.

Or if it is some invisible application window, you may try pressing Alt+Spacebar to get its window menu and move it around the screen...

tdrees
Posts: 10
Joined: 13 Dec 2005, 20:14

Re: Focus gets lost after COPY,MOVE

Post by tdrees » 09 Dec 2010, 10:10

OK, I got it. It is the new V6 of TeamViewer (http://www.teamviewer.de), a remote-controlling software. If it is diabled, the problem does not occur.

@Jan: Do you have the chance to check, whats going on there?

Regards,

Torsten

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5126
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Focus gets lost after COPY,MOVE

Post by Jan Rysavy » 09 Dec 2010, 10:55

Great! Looks like a bug in TeamViewer v6. I will look at it.

You should try to contact TV support.

tdrees
Posts: 10
Joined: 13 Dec 2005, 20:14

Re: Focus gets lost after COPY,MOVE

Post by tdrees » 09 Dec 2010, 11:21

Jan, this is what I have done in parallel. I will let you any news from TeamViewer.

tosiabunio
Posts: 7
Joined: 23 May 2007, 17:54

Re: Focus gets lost after COPY,MOVE

Post by tosiabunio » 23 Feb 2011, 21:42

Any news about this? I've just installed TeamViewer and noticed this annoying behavior. Unfortunately I must use TV for next few weeks...

tdrees
Posts: 10
Joined: 13 Dec 2005, 20:14

Re: Focus gets lost after COPY,MOVE

Post by tdrees » 25 Feb 2011, 17:15

Yes, I have, you have to change configuration of TV. See attached hardcopy.
Attachments
teamviewer.jpg
teamviewer.jpg (330.56 KiB) Viewed 7331 times

tosiabunio
Posts: 7
Joined: 23 May 2007, 17:54

Re: Focus gets lost after COPY,MOVE

Post by tosiabunio » 25 Feb 2011, 17:19

Thanks. That worked.

Post Reply