Cannot delete file, cannot read source...

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
Pimpa
Posts: 3
Joined: 11 Aug 2010, 11:15

Cannot delete file, cannot read source...

Post by Pimpa » 11 Aug 2010, 11:25

Hi,

If I have a file with name contains these characters (ű,ő) the Salamander's panel replaces them with (u,o) accordingly.
Trying to delete, copy or move this file, it is impossible. I got a message "Cannot delete file: Cannot read from the source file or disk."

I tried to set Panel Font MS Sans serif Western to Central European, but nothing changed.

Any suggestions please?
This problem is in Salamander 2.53 now, but in any earlier versions too.

Thanks,
Pimpa

omega
Posts: 177
Joined: 09 Dec 2005, 19:21

Re: Cannot delete file, cannot read source...

Post by omega » 11 Aug 2010, 16:33

ű and ő are not in the ASCII standard but in ISO 8859-2

User avatar
Ether
Posts: 1459
Joined: 10 May 2007, 16:08
Location: Czech Republic
Contact:

Re: Cannot delete file, cannot read source...

Post by Ether » 11 Aug 2010, 21:04

Can you handle those files properly in Windows Explorer? If so, are there any other non-ASCII (i.e. not in the English alphabet) characters you encounter in your file names? If not, you could change your non-Unicode locale to German (I assume those are standard umlauted o and u contained in the Windows' German character set). That should take care of any further problems.

For more information and a walkthrough, refer to the Unicode Support page in Salamander's help.

If that doesn't solve your problems, please tell us the version and language of your Windows, as well as the value of the non-Unicode locale setting.
Ελληνικά rulez.

Pimpa
Posts: 3
Joined: 11 Aug 2010, 11:15

Re: Cannot delete file, cannot read source...

Post by Pimpa » 12 Aug 2010, 11:46

Ether wrote:Can you handle those files properly in Windows Explorer? If so, are there any other non-ASCII (i.e. not in the English alphabet) characters you encounter in your file names? If not, you could change your non-Unicode locale to German (I assume those are standard umlauted o and u contained in the Windows' German character set). That should take care of any further problems.

For more information and a walkthrough, refer to the Unicode Support page in Salamander's help.

If that doesn't solve your problems, please tell us the version and language of your Windows, as well as the value of the non-Unicode locale setting.
Yes, I can handle these files in Windows Explorer properly. File names contains other non-ASCII characters, but only this two causes error. The mentioned Unicode Support Help solved my problem.
Thanks a lot.

Regards

tpalenik
Posts: 1
Joined: 17 Nov 2013, 08:47

Re: Cannot delete file, cannot read source...

Post by tpalenik » 17 Nov 2013, 09:06

It happens also with many other accented characters.

Easy steps to replicate: In windows explorer create a folder named "Čeština".
Now try to open or move or delete it in Altap Salamander - you get an error.
Windows explorer and other file managers handle this with no problem.
This is a VERY serious problem for a file management software - Altap team, please fix.

Tried multiple times on several Windows 7 versions (32 and 64 bit - all english systems).
Altap salamander ver 2.54.

lexa
Posts: 10
Joined: 09 Aug 2013, 18:36
Location: Germany (HZ)

Re: Cannot delete file, cannot read source...

Post by lexa » 21 Jan 2014, 19:41

Ether wrote:I assume those are standard umlauted o and u contained in the Windows' German character set
ű and ő are not German, we have Ä + Ö + Ü + ä + ö + ü + ß (Umlaute) and I had never any Problem with that chars since Salamander v1.51 and Windows 95.
Just my 2 cents :wink:
Regards, Axel

User avatar
Ether
Posts: 1459
Joined: 10 May 2007, 16:08
Location: Czech Republic
Contact:

Re: Cannot delete file, cannot read source...

Post by Ether » 23 Jan 2014, 16:41

lexa wrote:ű and ő are not German
My fault, thanks for noting that. They're actually Hungarian characters. Also, German characters are contained in the default English character set (Win-1252 / ISO-8859-1 / CP437).
tpalenik wrote:Now try to open or move or delete it in Altap Salamander - you get an error.
In case you know the characters you'll be working with in advance, you can change your "non-Unicode locale" setting to a different language or use AppLocale. Alternatively, if none of the provided national character sets suit your needs, there is an unofficial way to create a custom character set. If you need any help, let us know.
Ελληνικά rulez.

Post Reply