Mapped network drives not visible

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
Jirina
Posts: 2
Joined: 30 Jul 2010, 08:49

Mapped network drives not visible

Post by Jirina » 30 Jul 2010, 08:57

I use Altap Salamander 2.53 on Windows 7 Professional 64-bit and I always run it as administrator. My problem is that I can't see mapped network drives neither in the drop down menu (Alt+F1), nor in the drive bar. However, I can see and browse them in Windows Explorer and they are available to all programs trying to open a file, so I assume there is something wrong in Salamander itself. Could it be any settings which I don't see?

I have a .bat file to map network drives. If I run it from Windows Explorer, AS does not display the mapped drives, but if I run the .bat file from AS, the mapped drives appear in the list!

I checked Firewall settings and even disabled the firewall (I only use the default Windows firewall), but this did not help. I use NOD32, version 4, business edition, but I think it should not be related to the problem I have.
Last edited by Jirina on 30 Jul 2010, 09:19, edited 1 time in total.

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Mapped network drives not visible

Post by Jan Rysavy » 30 Jul 2010, 09:17

When you start Salamander as standard user (without escalation to Administrator), can you see your mapped drives?

Jirina
Posts: 2
Joined: 30 Jul 2010, 08:49

Re: Mapped network drives not visible

Post by Jirina » 30 Jul 2010, 09:26

Indeed, starting AS in the standard mode (not as administrator) helped - I can see mapped network drives even if the .bat file for mapping was ran from Windows, not from AS. Thank you!

Let me just add an interesting point that if AS is ran as administrator and the batch file is run from it, AS displays the list of drives correctly, but Windows don't display anything.

therube
Posts: 626
Joined: 14 Dec 2006, 06:22

Re: Mapped network drives not visible

Post by therube » 30 Jul 2010, 09:29

WinXP Pro SP3 or Win7 x86 | SS 2.54

User avatar
SelfMan
Posts: 955
Joined: 05 Apr 2006, 20:51
Contact:

Re: Mapped network drives not visible

Post by SelfMan » 02 Aug 2010, 07:07

Jirina wrote:Let me just add an interesting point that if AS is ran as administrator and the batch file is run from it, AS displays the list of drives correctly, but Windows don't display anything.
This is becaute drive mapping works under user context.
If you run something as administrator, you are runnig it as a different user.

Post Reply