Incorrect Russian characters

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
Baptist
Posts: 3
Joined: 18 Jul 2010, 14:21

Incorrect Russian characters

Post by Baptist »

Altap Salamander 2.53 doesn't support Russian characters in almost all controls: directory line (title of file panel); information line; command prompt line; hot path bar.

Setting Configuration/Appearance/Panel Font lets to set 'Script' to 'Cyrillic' but it works only for file list panel, not for any other control. And, I believe, setting "use standard system fonts" should be enough to show correct characters without manual changing of Script.

Command prompt line lets to enter (and correctly shows) Russian characters but doesn't show them in current directory part.

I use English Windows 7 x64 with setting about non-Unicode programs set to "Russian (Russia)".
Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5197
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Incorrect Russian characters

Post by Jan Rysavy »

Could you please post some screenshots?
It looks like problem with fonts.
Baptist
Posts: 3
Joined: 18 Jul 2010, 14:21

Re: Incorrect Russian characters

Post by Baptist »

Attached 'Capture.jpg'. The same word in different controls. Greens are good, reds are wrong.
Attachments
Capture.jpg
Capture.jpg (85.11 KiB) Viewed 6395 times
Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5197
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Incorrect Russian characters

Post by Jan Rysavy »

Thank you. We have another (Czech) thread with probably same problem http://forum.altap.cz/viewtopic.php?f=6&p=20195.
It looks like you changed something in your Windows (font, related settings, etc) and OS is using wrong font.

Could anyone else reproduce this problem? Please let us know.
Baptist
Posts: 3
Joined: 18 Jul 2010, 14:21

Re: Incorrect Russian characters

Post by Baptist »

I changed my 'Language for non-Unicode programs' to 'English (United States' then restarted Windows then set 'Language for non-Unicode programs' back to Russian then restarted again. May be, there were some other operations with switching Windows settings forth and back (I don't remember them all)... It helps! Now I can see Russian in all dialogs and controls. So, I think, it was a bug in Windows 7 with setting of default encoding.
Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5197
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Incorrect Russian characters

Post by Jan Rysavy »

Thank you for the information!
SergeySerbezov
Posts: 1
Joined: 13 Dec 2017, 10:36

Re: Incorrect Russian characters

Post by SergeySerbezov »

The same story after the "Feature update to Windows 10, version 1709". I changed the system language for non-Unicode to English, restated, than back to Bulgarian (restart), and the cyrillic vizualization recovered.
Post Reply