Logitech MX510 mouse forward/back don't work on Windows 10

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
GrimmReaperNL
Posts: 18
Joined: 24 Oct 2009, 01:46

Logitech MX510 mouse forward/back don't work on Windows 10

Post by GrimmReaperNL » 08 Dec 2015, 22:15

I have a logitech MX510 with drivers installed on windows 10.

The forward/back buttons on the side of the mouse don't take me to the previous and next folders i was in anymore.

Can anyone help me with this problem?

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Forward/back buttons on my mouse don't work on windows 1

Post by Jan Rysavy » 08 Dec 2015, 22:32

We are catching WM_APPCOMMAND message. APPCOMMAND_BROWSER_BACKWARD and APPCOMMAND_BROWSER_FORWARD. It looks like MX510 driver doesn't send this message.

Does back/forward button work with Firefox, Internet Explorer, Windows Explorer, ...?

GrimmReaperNL
Posts: 18
Joined: 24 Oct 2009, 01:46

Re: Forward/back buttons on my mouse don't work on windows 1

Post by GrimmReaperNL » 08 Dec 2015, 23:18

Forward/back does work in Chrome and windows explorer.

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Forward/back buttons on my mouse don't work on windows 1

Post by Jan Rysavy » 09 Dec 2015, 10:35

Has anyone else Windows 10 and Logitech mouse problem with back/forward buttons? Does anyone use this combination?

Looks like Logitech related problem, I have tested Windows 10 with Microsoft IntelliMouse Explorer 2.0 mouse and back/forward buttons works fine with Altap Salamander 3.06.

Updated thread subject.

jsm
Posts: 9
Joined: 01 Dec 2013, 21:15

Re: Logitech MX510 mouse forward/back don't work on Windows

Post by jsm » 09 Dec 2015, 20:59

I'm using Logitech Marathon Mouse M705 under Windows 10 Pro and all works fine. I have installed default drivers distributed in Windows 10 and Altap Salamander 3.06 64-bit.

GrimmReaperNL
Posts: 18
Joined: 24 Oct 2009, 01:46

Re: Logitech MX510 mouse forward/back don't work on Windows

Post by GrimmReaperNL » 10 Dec 2015, 14:45

The replies made me try without the logitech driver software running.
The forward/back buttons now work without a problem.

So this can be closed, not a Salamander bug :D

GrimmReaperNL
Posts: 18
Joined: 24 Oct 2009, 01:46

Re: Logitech MX510 mouse forward/back don't work on Windows

Post by GrimmReaperNL » 10 Dec 2015, 16:56

If anyone ever runs into this problem, make sure the driver software is run in compatibility mode for windows 7 (have not tried 8) and in administrator mode for good messure.
I can now use my forward/back buttons again :D

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Re: Logitech MX510 mouse forward/back don't work on Windows

Post by Jan Rysavy » 10 Dec 2015, 17:00

Do you run also Salamander as Administrator?

GrimmReaperNL
Posts: 18
Joined: 24 Oct 2009, 01:46

Re: Logitech MX510 mouse forward/back don't work on Windows

Post by GrimmReaperNL » 11 Dec 2015, 03:15

Yes, I do. As windows 10 is a total sh*thole when it comes to permissions.

I still can't drag and drop files from a windows explorer window into a salamander window, but a cut/paste works just fine.

TheCraigus
Posts: 3
Joined: 23 Jan 2011, 18:58

Re: Logitech MX510 mouse forward/back don't work on Windows

Post by TheCraigus » 23 Dec 2015, 10:00

Are these all cases of the back/forward working for a while and then stopping? I've had this happen on several systems and haven't yet found a solution. I even tried uninstalling and reinstalling Salamander with no luck. My logitech back/forward buttons work for anything up to a few months and then stop. No updates to logitech drivers installed or anything like that and Salamander is the only app where they no longer work. At the same time, certain shell extensions stop working - always Beyond Compare and, in some cases, my Vim extension shortcuts as well. So either it's not just related to running the logitech drivers in compatibility mode (or using default drivers which partially cripple the mouse) after something in the system decides they shouldn't work correctly with Salamander anymore or the shell extensions and mouse coincidentally stop working.

Post Reply