FULL version will not install on Win2k

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
cincura.net
Posts: 593
Joined: 09 Dec 2005, 17:30
Location: a step further
Contact:

Post by cincura.net » 28 Mar 2007, 21:26

Anne wrote:NEW INFO.. I have found that if I try multiple time to extract the SALAMAND.exe file, from the ss25rc2f.7z using the STANDARD version of Salamander, that the Salamand.exe file will sometimes extract without an error.
This could be also problem with RAM...
Jiri {x2} Cincura

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Post by Jan Rysavy » 28 Mar 2007, 21:50

Thank you for confirming the think with multiple extraction. It looks like there is some (random) bug in 7-zip extraction code. We should really switch to latest source code.

Thank you for your effort. We will release Salamander 2.5 RC3 during next week (and final version 2.5 two weeks later), please let us know if installation works on your computer.

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Post by Jan Rysavy » 28 Mar 2007, 21:53

cincura.net wrote:This could be also problem with RAM...
Good point! We are using this nice memory test: http://www.memtest.org/ with prebuild ISO images http://www.memtest.org/#downiso but I don't want to bother Anne anymore :)

User avatar
SelfMan
Posts: 961
Joined: 05 Apr 2006, 20:51
Contact:

Post by SelfMan » 28 Mar 2007, 22:44

Could you try the same extract-action using WinRar?
http://www.rarsoft.com/rar/wrar362.exe

cincura.net
Posts: 593
Joined: 09 Dec 2005, 17:30
Location: a step further
Contact:

Post by cincura.net » 28 Mar 2007, 23:42

Jan Rysavy wrote:Good point! We are using this nice memory test: http://www.memtest.org/ with prebuild ISO images http://www.memtest.org/#downiso but I don't want to bother Anne anymore :)
I'm using it too. But as you noticed, probably bug in 7z extraction.
Jiri {x2} Cincura

Anne
Posts: 19
Joined: 09 Mar 2006, 00:10
Location: Florida

Post by Anne » 29 Mar 2007, 00:23

SelfMan wrote:Could you try the same extract-action using WinRar?
http://www.rarsoft.com/rar/wrar362.exe
Using WinRAR 3.62 on the file ss25rc2f.7z gives two messages
"The archive is either in unknown format or damaged" or
"no archives found in selected files and folders"
depending on the action taken by WinRAR

Anne

Anne
Posts: 19
Joined: 09 Mar 2006, 00:10
Location: Florida

Post by Anne » 29 Mar 2007, 00:28

Jan Rysavy wrote:
cincura.net wrote:This could be also problem with RAM...
Good point! We are using this nice memory test: http://www.memtest.org/ with prebuild ISO images http://www.memtest.org/#downiso but I don't want to bother Anne anymore :)
I ran memtest 86 from floppy for about 12 hours before I reinstalled the OS.

No errors in my 512mb of mem

Anne

Anne
Posts: 19
Joined: 09 Mar 2006, 00:10
Location: Florida

Post by Anne » 29 Mar 2007, 21:25

NEW INFORMATION

I changed my motherboard settings from OPTIMAL to STANDARD.

Now I can SOMETIMES get the ORIGINAL file "ss25rc2f.exe" to extract and install correctly with no errors.

This is the FIRST time I have been able to do this with the original .exe file since my reformat and reinstall of the OS.

Anne

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Post by Jan Rysavy » 29 Mar 2007, 23:06

It looks like some hardware dependent problem. Did you notice other unusual problems with your computer?

Anne
Posts: 19
Joined: 09 Mar 2006, 00:10
Location: Florida

Post by Anne » 30 Mar 2007, 06:27

Jan Rysavy wrote:It looks like some hardware dependent problem. Did you notice other unusual problems with your computer?
No, did not notice any other problems other than Salamander.

It looks to me like a timing issue with the extraction process and the particular file. I have had no other problems with file extractions.

I continue to install other software and everything works just fine.

Post Reply