Shortcut not working

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
Guest

Shortcut not working

Post by Guest » 13 Sep 2006, 16:55

Hello,

I use German keyboard layout. Thus, ; and . are on the very same key, ; is the 'upper case' letter so to say.
However, I can't use the ctrl+; shortcut for going to "My Documents" - it always takes be to the 'Change Drive' dialog (that is used for ctrl+, - Network Neighborhood).

User avatar
th.
Posts: 116
Joined: 04 Sep 2006, 23:09
Location: Germany

Post by th. » 13 Sep 2006, 20:43

On a German keyboard the shortcut for "My Documents" is Ctrl+ü.

User avatar
Georgd
Posts: 98
Joined: 24 Jul 2006, 17:13

Show _real_ Hotkeys, not the ones for en locale

Post by Georgd » 08 Oct 2006, 19:07

Some other hotkeys as well are shown in the menu with another key than actually has to be used. Could Salamander display the keys the user actually has to press in the current locale, instead of the english locale ones? That'd help to learn & remember them...

Jan Rysavy
ALTAP Staff
ALTAP Staff
Posts: 5196
Joined: 08 Dec 2005, 06:34
Location: Novy Bor, Czech Republic
Contact:

Post by Jan Rysavy » 09 Oct 2006, 17:19

We can change hot keys for national (German, French) versions of Salamander. Thank you for this idea!

User avatar
Georgd
Posts: 98
Joined: 24 Jul 2006, 17:13

Post by Georgd » 09 Oct 2006, 21:09

Jan Rysavy wrote:We can change hot keys for national (German, French) versions of Salamander. Thank you for this idea!
Welcome :) and maybe I expressed it ambigous thus clarification: I don't want different hotkeys for the still-to-come localized versions of Salamander. I just want Salamander to display the keys I have to press on this computer with the current keyboard locale (might change several times during a session).
Using Salamander since v 1.52

User avatar
Georgd
Posts: 98
Joined: 24 Jul 2006, 17:13

Re: Shortcut not working

Post by Georgd » 26 Nov 2009, 16:05

Just to bring it up again - it is hard to remember the real keys. Would be nice to see them left of the name, e.g. ü instead of ; for documents.
ImageImage
Using Salamander since v 1.52

User avatar
th.
Posts: 116
Joined: 04 Sep 2006, 23:09
Location: Germany

Re: Shortcut not working

Post by th. » 04 Dec 2009, 12:06

The problem is that in the menu the ; key (which is displayed) is working but not the ü. On the other hand Ctrl-; isn't working but Ctrl-ü is.
I guess for the hotkeys the scan codes of the keys are used (interpreted as a standard english keyboard) but in the menu the characters with respect to the locale settings.

User avatar
Georgd
Posts: 98
Joined: 24 Jul 2006, 17:13

Re: Shortcut not working

Post by Georgd » 09 Feb 2011, 13:56

bump :)
Using Salamander since v 1.52

User avatar
Georgd
Posts: 98
Joined: 24 Jul 2006, 17:13

Re: Shortcut not working

Post by Georgd » 20 Apr 2012, 22:24

bump :( Displaying the same keys that have to be pressed would still be helpful...
Using Salamander since v 1.52

Post Reply