USB Devices Not Found in Altap Salamder

Discussion of bugs and problems found in Altap Salamander. In your reports, please be as descriptive as possible, and report one incident per report. Do not post crash reports here, send us the generated bug report by email instead, please.
User avatar
jcgriff2
Posts: 35
Joined: 20 Aug 2008, 21:34
Location: New Jersey, USA
Contact:

USB Devices Not Found in Altap Salamder

Post by jcgriff2 » 11 May 2017, 05:40

I sometimes copy files from my phone or GPS (it has a built-in camera) to my laptop. I would very much like + prefer to use Altap Salamander for such tasks, but so far, I see no option to select the attached-by-USB-cable device or any of its folders/files anywhere in Salamander.

The devices do appear in Windows File Explorer - but not as a device or new drive, rather as a new folder under the "This PC" heading.

Here is a Windows File Explorer screenshot showing the GPS/camcorder device (but nothing came up in Altap Salamander):

CLICK PIC TO ENLARGE

Image


When the USB cable-connected phone or GPS/camcorder is unplugged, the mysterious directory goes away as well. It's like a brain-teaser as nothing appears in the Event Viewer logs (all ~250 of them!) -- as if connecting the USB device; copying files from it to PC; removal of the USB cable/device never happened.

Not sure if it matters or not, but my phone is an android Samsung Galaxy 3. Again, I am unable to find a way to use Altap for file transfers/copying files between my phone and laptop. The USB cable I use is usually a generic one - mini-USB to USB.

Any suggestions or ideas? I want to use Salamander because it is easier + Altap copies files much, much faster than Windows File Explorer. Earlier tonight, I had to copy 372 MP4 files (27.8 GB) from the GPS/camcorder and it took Windows 8.1 x64 nearly 4 hours to do the copying. The MP4 files were from a ~6 hour drive, which I will repeating daily for the next 3 weeks. I know that Salamander can do it faster.

Thanks for your help,

John
J. C. Griffith
Microsoft MVP
Windows Expert - IT Pro
http://mvp.microsoft.com/en-us/mvp/John%20C.%20Griffith-4025562

Hadez
Posts: 26
Joined: 15 Jan 2006, 14:52

Re: USB Devices Not Found in Altap Salamder

Post by Hadez » 13 May 2017, 11:10

It seems that neither device uses the USB Mass Storage Mode (in this mode, raw data is presented to the system, and you can map it to a drive letter). Try to check if you can switch your phone from MTP (which makes you see the storage only under "This PC") to UMS first.

There was some initial work on the Portable Devices plugin but since this January, there has been no reported progress. You might want to bump the thread.

User avatar
jcgriff2
Posts: 35
Joined: 20 Aug 2008, 21:34
Location: New Jersey, USA
Contact:

Re: USB Devices Not Found in Altap Salamder

Post by jcgriff2 » 28 May 2017, 13:19

Thank you for the reply and I will try your suggestions.

I am currently on a 6,000 mile road trip between NJ, Texas and Florida. I am still in Florida, putting my return trip off as long as possible to continue to enjoy the beaches & pools + 95°F daily temps with 95% humidity.

Thanks,
John
J. C. Griffith
Microsoft MVP
Windows Expert - IT Pro
http://mvp.microsoft.com/en-us/mvp/John%20C.%20Griffith-4025562

Post Reply