PDF thumbnails don't show anymore

Support for developers of new plugins, third-party plugin announcements and discussions.
User avatar
otrov
Posts: 110
Joined: 10 Feb 2010, 04:39

PDF thumbnails don't show anymore

Post by otrov » 28 Mar 2011, 01:37

False alarm, sorry: http://forum.altap.cz/viewtopic.php?f=1 ... 096#p22096

I don't know if PDF thumbnails are handled by explorer thumbnail plugin which I have installed or by AS itself, but today I noticed that I can't see thumbnails for my PDFs in AS
I opened explorer and everything seems fine there. Problem could be that I've installed IE9, but that's wild guess

Does anyone have same issue? Is it possible to solve?

Thanks

[edit] It's also same for DjVu files. I have DjVu shell extension from caminova, but it also stopped to show inside AS
Last edited by otrov on 22 Apr 2011, 22:23, edited 2 times in total.

User avatar
SelfMan
Posts: 924
Joined: 05 Apr 2006, 20:51
Contact:

Re: PDF thumbnails don't show anymore

Post by SelfMan » 29 Mar 2011, 00:02

Have you disabled the Eroiica plugin?

User avatar
otrov
Posts: 110
Joined: 10 Feb 2010, 04:39

Re: PDF thumbnails don't show anymore

Post by otrov » 29 Mar 2011, 02:09

I don't have Eroiica plugin - I didn't installed it

Now I think I posted in wrong forum, as I'm almost sure problem is with explorer thumbnail plugin and IE9
Can someone confirm this behavior, and if possible, moderator to move this to explorer thumbnail plugin thread?
Thanks

User avatar
Ether
Posts: 1459
Joined: 10 May 2007, 16:08
Location: Czech Republic
Contact:

Re: PDF thumbnails don't show anymore

Post by Ether » 29 Mar 2011, 21:21

SelfMan wrote:Have you disabled the Eroiica plugin?
Eroiica plugin works fine.
otrov wrote:Now I think I posted in wrong forum, as I'm almost sure problem is with explorer thumbnail plugin and IE9
Can someone confirm this behavior
I can partially confirm - I've got IE9 and I've disabled Eroiica plugin and my PDF thumbnails are blank. I don't have a system without IE9 at the moment, so I can't confirm IE9 really is the culprit.
otrov wrote:moderator to move this to explorer thumbnail plugin thread?
Just post a link to this topic with a short explanation there.
Attachments
Clipbrd1.png
Explorer Thumbnails on the left, Eroiica on the right.
Clipbrd1.png (59.38 KiB) Viewed 14089 times
Ελληνικά rulez.

klonuo
Posts: 4
Joined: 26 May 2011, 12:07

Re: PDF thumbnails don't show anymore

Post by klonuo » 26 May 2011, 12:15

Hello,

I have similar problem, which is perhaps slightly different, because I use XP SP3 32b

Image

As you can see, Salamander shows these ugly icons instead thumbs (for PDF extracted first page, and for FLAC thumb - associated icon)
PDF are associated with Adobe Acrobat 7, and FLAC with foobar2000

Also I use explorer_thumb plugin and don't use Eroiica, as I found it performance regarding PDF thumbs extraction slow, then without caching, resulting in undesired behaviour for my low end P4 with 1GB RAM

Does someone know if this can be resolved by some setting in Exlorer of Salamader?

TIA

User avatar
SelfMan
Posts: 924
Joined: 05 Apr 2006, 20:51
Contact:

Re: PDF thumbnails don't show anymore

Post by SelfMan » 26 May 2011, 23:02

What are your settings in Options > Configuration > Drives ?
Any "use simple icons" checked? Are the affected files on a network drive?

klonuo
Posts: 4
Joined: 26 May 2011, 12:07

Re: PDF thumbnails don't show anymore

Post by klonuo » 28 May 2011, 03:37

"Use simple icons" isn't checked for any drive

This are local hard drives

User avatar
SelfMan
Posts: 924
Joined: 05 Apr 2006, 20:51
Contact:

Re: PDF thumbnails don't show anymore

Post by SelfMan » 29 May 2011, 01:11

Then it is possible, that your IconCache.db is corrupted. Locate the file in %userprofile%\AppData\Local (if on Win7) or C:\Documents and Settings\Your User Name\Local Settings\Application Data\Iconcache.db, rename it and reboot. Check if tyhe issue persists.
Before you can rename the file, you have to kill the explorer.exe process.

[edit]
There is a small freeware utility from Camtech 2000 - RefreshEm, which does the same.

klonuo
Posts: 4
Joined: 26 May 2011, 12:07

Re: PDF thumbnails don't show anymore

Post by klonuo » 29 May 2011, 12:00

Thanks for your suggestions

I'm running XP SP3

I've tried rebuilding icon cache (with Tweak UI) before I thought to post my problem here. Perhaps something else is wrong. I even reinstalled Acrobat 7, just in case, but without results in Salamander.

Other thumbs like AVI files, or others with custom shell extensions, like DjVu, are showing fine in Salamander, the same as in Explorer. But the ones I want most - PDF thumbs - simply don't want to show. I have large collection, and fast visual tracking is desired in many cases.

I've noticed also this strange behavior. For example consider this screen-shot:

Image

Now, if I select "Tiles" view in right panel, PDF icons in "Thumbs" view (in left panel) also changes:

Image

And just in current Salamander session. After restarting everything is like it was.

Just for clearance, I don't want to see associated PDF icons in thumbs view, but only thought to mention strange to me behavior.

User avatar
SelfMan
Posts: 924
Joined: 05 Apr 2006, 20:51
Contact:

Re: PDF thumbnails don't show anymore

Post by SelfMan » 29 May 2011, 17:11

Please verify the followin registry keys:

[HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics]
"Shell Icon BPP"="16"
"Shell Icon Size"="32"

[HKEY_CLASSES_ROOT\regfile\shell]
@="edit"

Twek UI likes to mess up the registry sometimes...

[edit]
Check also AS Options > Configuration > Viewers and Editors > "*.ppt;*.pct;*.pict;*.plt;*.prt;*.pdf;*.ps;*.eps;*.rdl;*.ris"
Is it associated with Eroiica Viewer (plugin) ?
Try:
Change to Internet Explorer Viewer (plugin)
OR
Temporary remove the .pdf extension from the list of assitiated extension.

Save AS configuration and restart te program. See whats happening.

klonuo
Posts: 4
Joined: 26 May 2011, 12:07

Re: PDF thumbnails don't show anymore

Post by klonuo » 29 May 2011, 18:03

SelfMan wrote:[HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics]
"Shell Icon BPP"="16"
"Shell Icon Size"="32"
both are present
SelfMan wrote: [HKEY_CLASSES_ROOT\regfile\shell]
@="edit"
entry "reg:\HKEY_CLASSES_ROOT\regfile\shell\edit" is present, if that's what you meant
there is no "@" value with "edit" value data, but I created one then restarted Salamander with no effect
SelfMan wrote: Check also AS Options > Configuration > Viewers and Editors > "*.ppt;*.pct;*.pict;*.plt;*.prt;*.pdf;*.ps;*.eps;*.rdl;*.ris"
Is it associated with Eroiica Viewer (plugin) ?
No, I disabled Eroiica because plugin is slower then Adobe shell extension and does not cache data, so I have to wait long time for my larger folders to show their thumbs. I could use Eroiica, but I'm trying Salamander as I found it performance and features like nothing else, and it seems petty if it's outperformed by Explorer for some feature I use often. Above all, I guess "Explorer thumbs" plugin does that job for Salamander.

I had PDF associated with external viewer - SumatraPDF. I removed viewer association, restarted Salamander, and unfortunately it's same.


Thanks for your time, maybe it's some other registry setting, but as I showed earlier in Explorer everything is fine

User avatar
SelfMan
Posts: 924
Joined: 05 Apr 2006, 20:51
Contact:

Re: PDF thumbnails don't show anymore

Post by SelfMan » 29 May 2011, 18:13

Then check if the explorer thumbnail plugin is property installed and enabled.
Try one more thing tho, create a new dummy user account and check what happens there when you log in as a different user.
Other than that, at the moment I have no further ideas what would cause this.

Post Reply