Altap Salamander 2.54 SDK

Support for developers of new plugins, third-party plugin announcements and discussions.
Petr Solin
ALTAP Staff
ALTAP Staff
Posts: 1104
Joined: 08 Dec 2005, 09:13
Location: Novy Bor, Czech Republic
Contact:

Altap Salamander 2.54 SDK

Post by Petr Solin » 28 Jun 2010, 11:08

The Altap Salamander SDK is set of tools, documentation and code samples you need to create plugins (add-ons) that can run inside Altap Salamander.

News in 2.54 SDK:
  • New DemoMenu plugin: it is really the simplest plugin possible, it only adds one item to Plugins menu, please do not hesitate and try to use it as base for your own menu extension plugins:
    demomenu.png
    DemoMenu plugin
    demomenu.png (21.85 KiB) Viewed 3509 times
  • New DemoView plugin: simple base for your viewer plugins:
    demoview.png
    DemoView plugin
    demoview.png (22.41 KiB) Viewed 3509 times
  • Source code of UnFAT plugin was published in this SDK. We believe you will find here most of needed techniques for building your own archiver plugins.
We recommend to use Altap Salamander 2.53 beta 1 (PB 44) to test your plugins because it contains trace messages helpful for plugins development. These messages are collected by Altap Trace Server which is enclosed to this version of Salamander and can be auto-started whenever you start this version of Salamander. You can also log trace messages to file in TEMP directory, see Salamander's Window Menu (click on icon in upper left corner of main window).[/hide]
We recommend to use Altap Salamander 2.54 (SDK) which is available in SDK package to test your plugins because it contains trace messages helpful for plugins development. These messages are collected by Altap Trace Server which is enclosed to this version of Salamander and can be auto-started whenever you start this version of Salamander. You can also log trace messages to file in TEMP directory, see Salamander's Window Menu (click on icon in upper left corner of main window).

Requirements:
-Microsoft Windows 2000, XP, Vista, or Windows 7.
-Microsoft Visual C++ 6.0, Microsoft Visual C++ 2005, Microsoft Visual C++ 2008 (including Express Edition), or Borland C++ Builder 6.0, 2009, or 2010.
-Or Delphi compiler with unofficial SDK for Delphi.
-Microsoft HTML Help Workshop 1.3 as help compiler (optional)

Unfortunately, due to lack of time the documentation is available only in Czech as comments in the header files. We hope the community will help us translate it to English and convert to HTML/PDF format.

For your questions and feedback please use this discussion forum.

If you want to develop plugins for Altap Salamander 2.5, 2.51, 2.52, 2.53, and 2.54 easiest way is to use Altap Salamander 2.5 SDK (plugins for version 2.5 works also with all 2.5x versions). If you need to use newer SDK, you can still make your plugin backward compatible with version 2.5, see salamand\plugins\shared\doc\compatibility.txt in SDK.

Altap Salamander 2.54 SDK Download
Altap Salamander 2.53 SDK Download
Altap Salamander 2.52 SDK Download
Altap Salamander 2.51 SDK Download
Altap Salamander 2.5 SDK Download